Content & SEO: Keyword Research feature outage
Resolved
Our tech team reports that a fix could be implemented for this issue. The Keyword Research features are working again. In case you're still experiencing any issues please reach out to ask@sellics.com.

Thank you for your patience.
Posted May 06, 2021 - 14:02 CEST
Identified
We are experiencing issues in the Keyword Research feature that affect a bigger part of all Sellics accounts. At the moment no results are showing for any marketplace (keyword and ASIN lookup). The team is already working on a fix with high prioritization, and we will inform our clients here as soon as there is an update.

If you have any questions please reach out to ask@sellics.com. Thank you for your patience.
Posted May 05, 2021 - 10:18 CEST
This incident affected: Content & SEO.